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About NetCD NetCD is a CD player utility for the Mac OS. NetCD can retrieve CD information from the

CDDB internet database or from user input and can store information on the hard disk

in the CD Remote Programs file, the same file used by Apple’s CD Remote and AppleCD

Audio Player utilities. NetCD is System 7 and OS 8 compatible, Appearance Manager

compliant, supports AppleScript, Balloon Help and Contextual Menus, and works with

both SCSI and IDE CD-ROM drives.

Requirements To use NetCD, you must have a Mac OS Computer with a 68040 processor or better and a
CD-ROM drive. To use the internet features, you must have Open Transport installed on
your computer with either a modem or a direct internet connection. Because I am not
able to forsee every possible combination of CD-ROM drives, computers and system
software, your results may vary.

Installing NetCD If you have received NetCD as a compressed archive, double-click the archive to
decompress the program. If you would like NetCD to appear in your Apple menu, place
the program or an alias to it in the Apple Menu Items folder in your System folder.

CD Remote Programs When NetCD is set to record CD program information to your hard disk, it places this 

and NetCD Extra Data information in a file called CD Remote Programs. This file is located in the Preferences
folder in your System folder. CD Remote Programs is used by other audio CD programs
such as CD Remote and AppleCD Audio Player. If you have entered other CD
information using these programs, you might want to make a backup copy of this file
before using NetCD.

NetCD also uses a second file in your preferences folder, NetCD Extra Data, to store extra
information about the disc and individual tracks. This file is not used by other programs
such as AppleCD Audio Player.

Modem Connections If you use a modem to connect to the internet, you must have Open Transport and a
PPP or SLIP connection to use NetCD. These protocols create a virtual “direct
connection” to the internet over your modem. As with most internet-based programs
on the Macintosh, NetCD will automatically start your PPP or SLIP connection when it
needs to connect to the internet. Like other programs, it does not terminate the
connection when done, but leaves it open for subsequent use.
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Starting NetCD To use NetCD, double-click on the program’s icon. If you have placed NetCD or an alias 
 for the First Time to it in the Apple Menu Items folder, you can start NetCD by choosing it from the Apple

Menu.

Figure 1: The Preferences Dialog Box.

When you open NetCD for the first time, the Preferences dialog box appears. Before
using NetCD, you must decide if and when you want NetCD to connect to the internet,
and provide it with some information concerning the connection.

1. Choose when you want to connect to the internet. NetCD allows you to specify the
circumstances under which the program should connect to the internet to retrieve CD
information. You can choose one of the options on the left side of the preferences
dialog box, each of which is described below:

Never. If you select Never, NetCD will not connect to the internet for CD
information. Use this option if you do not have an internet connection, or do
not wish to use NetCD’s internet capabilities.
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Only On Command. If you select this option, the Connect button in the main
window will be enabled and NetCD will download CD information from the
internet only when you click the Connect button.

For Unknown Discs. If you select this option, NetCD will always check the CD
Remote Programs file first to identify a CD. If there is no information in that file
for the CD, NetCD will retrieve information from the internet and display it.

For All Discs. If you select For All Discs, NetCD will download information from
the internet for every disc, even if that disc has been played previously.

If you choose one of the last three options, you can specify whether or not you want
NetCD to save downloaded information to your CD Remote Programs file. If you want
to save this information immediately after it has been downladed, make sure Save Titles
after Download is checked. If this option is not selected, NetCD will not save the
downloaded information unless it is subsequently edited.

As an example, on my computer at work, where I have a direct connection to the
internet, I use For Unknown Discs and Save Titles After Download. This way, when
NetCD finds a disc it does not recognize, it quietly checks the internet for the
information and saves it so it doesn’t have to check it again.  On my home computer,
where I use a modem to connect to the internet, I use Only On Command, so that
NetCD doesn’t tie up the phone line without my permission.

If Notify if No Match Found is checked, NetCD will notify you when it has searched the
CDDB and not found information for the current CD. It will then allow you to submit
information for the current CD to the database. If Notify if No Match Found is not
checked, NetCD will not give you this warning dialog.

If you chose Never in step 1, you can skip steps 2 and 3, since they apply only to internet
connections.

2. Choose a CDDB server. NetCD connects to a CDDB server to retrieve CD program
information. There are CDDB servers all over the world, with new ones added
periodically. To choose a server, click Select New Server.

When you click Select New Server, NetCD opens the internet connection and downloads
the current list of servers from which you can choose.  After it has retrieved this list,
NetCD displays the list in a separate dialog box. Select a server that is geographically near
your location and click OK. The location of the new server is displayed above the Select
New Server button.
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For advanced users: Holding down the Option key while you click Select New
Server allows you to choose a CDDB server without downloading the list of
current servers. You must know the address and port of the server in order to
use this method, and it is only intended for users who have trouble connecting
to the main CDDB server to retrieve the list of server sites.

3. Enter your e-mail address and SMTP server. When NetCD connects to the CDDB
server, it needs to submit your e-mail address to log in. Your e-mail address is kept
completely private and is used only as identification, and it helps the people who operate
the CDDB servers know better who is using this free service.

If your SMTP server is different than the one in your e-mail address, you can enter it in
the SMTP server field. If you are unsure of what your SMTP server is, consult your
system administrator.

4. Change the connection timeout period, if necessary. When NetCD is connecting to a
server, it keeps track of how long it has been waiting for a reply. If, after a certain amount
of time, there has been no answer, NetCD will try the connection again. You can select
how long NetCD waits in by entering a number of seconds in the connection timeout
field. If you have a slow modem connection, enter a higher number here to give NetCD
more leeway. If you have a fast connection, enter a smaller number here to increase
connection speeds.

5. Select Connect Using HTTP if necessary. If your computer is connected to the Internet
through a proxy server or firewall, you may need to use HTTP in order to connect to the
CDDB servers. If you are unsure about your Internet connection, contact your system
administrator.

If you connect to the Internet using a proxy server, select Use Proxy and enter the name
of your proxy server. If you are unsure of the name of your proxy server, consult your
system administrator.

6. Choose Autoplay Audio CDs if desired. If you select this option, NetCD will
automatically begin playing an audio CD as soon as it is inserted into the CD-ROM drive.
Note that this feature works only for Audio CDs, and has no effect on data CD-ROMs.

7. Click OK to confirm your choices. If you missed a step, NetCD will ask you to make the
required choice. Once you click OK, your preferences are saved and you will not need to
enter your preferences again unless you wish to change them.
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The Main Window NetCD’s main window is shown in figure 2. Since NetCD is Appearance Manager-
compliant, the colors of the controls and window may be different depending on the
appearance settings for your computer.

If you do not see the whole window, click the disclosure triangle at the left of the volume
slider to show the lower part of the window. The controls in the window are explained
below.

Figure 2: NetCD’s Main Window.

CD Buttons. The seven buttons in the upper left hand corner of the window control the playback of
the audio CD. Clockwise from the top left, they are:

Play/Pause. This button plays the CD. When the CD is playing, this button
becomes the Pause button, which pauses the CD.
Stop.  This button stops the CD playback.
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Eject. This button ejects the CD from the CD-ROM drive. To open the CD-ROM
tray when no disc is in the drive, press the eject button on the drive itself. 
Forward Scan. Clicking and holding down this button moves forward rapidly
through the disc.
Backward Scan. Cliching and holding down this button moves backward rapidly
through the disc.
Next Track. This button begins playback at the beginning of the next track.
Previous Track. This button begins playback at the beginning of the previous
track.

CD Title Field. The title of the CD is displayed to the right of the CD buttons. If it is too long to be
displayed, only the first part is shown, followed by ellipsis (…).

Track Popup Menu. The tracks of the CD are listed both numerically and by title in the popup window below
the disc name. When closed, this popup menu shows the number of the track currently
playing. When you open the menu by clicking on it, the numbers and titles of all the
tracks are displayed. The currently playing track is selected. To begin playback at a
specific track, choose the track from this popup menu.

Time Display. The time display is to the right of the CD Title Field. By default, the display shows the
elapsed time, in minutes and seconds, for the current track. You can cycle through the
display options by clicking on the time display. The display can also be set to show other
information through the Display menu, which will be discussed later.

Disclosure Triangle. The disclosure triangle, located beneath the CD buttons, toggles between compact view
and expanded view. To switch views, click the button.

Information Button. Click on the small “i” to the left of the volume slider to show or hide the extra
information window. When there is extra information for the current disc, the
information button is highlighted.

Volume Slider. The volume slider appears to the right of the disclosure triangle. To control the volume
of the audio CD playback, drag the slider tab. The audio CD volume is independent of
the computer’s system volume. Clicking on the speaker icon to the left of the volume
slider temporarily mutes the volume; click on the icon again to reset normal volume.

Panning Slider. The panning slider appears to the right of the volume slider. To control the panning of
the audio CD playback, drag the slider tab. Clicking on the panning icon to the left of the
panning slider returns the panning to exact center.
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Title and Track Fields. In expanded view, the disc title and track titles are displayed in the edit fields in the
middle of the window.  These fields display the program information for the current CD
and can be changed by the user. To move between the fields, press the tab key or the
return key. You can use the standard edit functions (cut, copy, paste) in these fields. If
there are more than eleven tracks on the CD, you can use the scroll bar to the right to
view the titles of the other tracks. Clicking on the track number to the left of a field
automatically starts playback at that track.

The Connect Button. The connect button at the bottom of the window allows you to connect to the internet
to retrieve CD information. While NetCD is connecting to a CDDB server, this button
becomes the Cancel button, which, when clicked, will cancel the current internet
connection. This button may be dimmed according to your connection preferences,
which will be discussed later.

The Resize Box. The resize box is located at the lower right-hand corner of the window. To change the
width of the window, click on the resize box and drag it to the left or right. When you let
go, the window and its controls change to the new width.

NetCD’s Menus Nearly all of NetCD’s functions are available through the main window, but some of
NetCD’s features are available through the menus as well, which are explained below.

The Apple Menu. In addition to the items you have placed in the Apple Menu Items folder, the Apple
Menu contains two menu items:

About NetCD. This command displays a box describing NetCD.
About CDDB.  This command displays a box describing the CDDB service.

The File Menu. The File Menu contains commands dealing with the CD database.

Connect. This command causes NetCD to connect to the CDDB to download
information about the current disc.
Submit Revision. This command brings up the Submit Information dialog box
to submit a revised entry to the CDDB. To submit a revision, first use “Connect”
to download the current entry. Then make the appropriate changes and select
“Submit Revision.”
Catalog Mode. This command puts NetCD into Catalog Mode, which is
described in further detail below. To return to normal mode, choose this menu
item again to deselect it.
Quit. This command closes the NetCD program. Quitting the program does not
stop the CD. You can also quit NetCD by clicking the main window’s close box
at the left end of the title bar.
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The Edit Menu. The Edit Menu contains the standard Edit commands for the Macintosh. For more
information on these commands, consult the documentation that came with your
computer. The other commands available from the Edit menu are:

Copy Current Track. This command copies the name of the currently playing
track to the clipboard.
Copy All. This command copies the name of the entire program of the current
disc to the clipboard.
Preferences. This command displays the Preferences dialog box, where you can
view and change your connection preferences.
HTVCP Options. This command brings up a dialog box which allows you to
enable or disable HTVCP, a method for automatically checking for new versions
of NetCD.

The Disc Menu. The Disc Menu contains  a few commands specific to NetCD:

Play/Pause. This command changes depending on whether the CD is playing or
stopped. It’s effect is the same as pressing the Play/Pause button.
Stop.  This command has the same effect as pressing the Stop button.
Eject. This command has the same effect as pressing the Eject button.

Display. The Display submenu allows you to change the time display in the
main window. The current choice is marked with a check mark.
Show Disc Info. This command displays the extra information window, which
displays any extended information about the current CD. At the bottom of the
window is a popup menu from which you can choose the information you wish
to view. Information downloaded from the CDDB is displayed in this window,
and any changes or additions made are saved to your local CD database. When
the extra information window is visible, the menu item switches to Hide Disc
Info. 

The Scripts Menu. The Scripts Menu gives you the ability to specify how NetCD interacts with other
programs:

About the Scripts Menu. This command displays information about how the
Scripts menu works.
Installed Scripts. The remained of the Scripts menu is a listing of installed
Scripts available to NetCD. For more information about Scripts, read the section
below titled “NetCD & AppleScript.”

Contextual Menus. In addition to the menus in the menubar, you can access a contextual menu at any time
by holding the Control key and clicking the mouse in the NetCD main window. From the
contextual menu you can change the time display or access the connection preferences.
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Catalog Mode NetCD can be used to quickly catalog your entire CD collection using the CDDB. When
you choose “Catalog Mode” from the File menu, NetCD automatically searches the
CDDB for information on the current disc and downloads it. NetCD then ejects the CD
and waits for the next disc.

To turn off Catalog Mode, choose “Catalog Mode” from the File menu to deselect it.
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CDDB Submission If NetCD searches the internet database for your CD and doesn’t find a match, it will give
you the option of sending information about the CD to add to the internet database. All
information in the CDDB has been entered by users like you. The CDDB submission can
include all of the following information:

· Disc Artist and Title. These two items are entered into separate fields in the Submit
Information dialog box, and are displayed in the main CD window separated by a slash
(“They Might Be Giants / Factory Showroom”, for example).

· Track Titles.
· Extended Information. This is the information made visible by selecting “Show

Information” from the NetCD menu.

If you do not wish to submit CD information to the CDDB, click the Cancel button in the
Submit Information dialog box. If you do wish to send information to the CDDB, enter
the information into the fields and click the Send button. NetCD will submit the
information to the server. If it is rejected for some reason, you will receive an e-mail
message explaining why.

Please remember that the CDDB is a free service provided to everyone. With this in mind,
please observe the following guidelines when submitting CD information to the
database:

· Do not submit information for homemade compilation CDs or other unique discs.
Since no one else is able to take advantage of this information, these submissions
simply clutter the database needlessly.

· Feel free to use accented characters where appropriate. For instance: “André Previn and
Orchestre Révolutionnaire et Romantique / The Music of Henryk Górecki and Arvo
Pärt” (Though I’m quite certain we won’t be seeing this CD anytime soon...)

· Take advantage of the extra information fields. Some users use this feature to include
lyrics, libretti, performance information or other pertinent data. Please avoid personal
opinions or experience, however.

· Make sure each track has a title. If the CD does not list a title for the track and you do
not know it, use “[Untitled].”

· If the CD has more than one artist, use the phrase “Various Artists” for the artist field
and include the artist for each track in the extra information field for that track.

· Use appropriate capitalization. In most cases, the capitalization used on the CD case is
fine. Do not use all capitals, however; if the CD case does, use proper song title
capitalization (which means capitalizing every word, as in “I Wouldn’t Normally Do This
Kind Of Thing”).

· Proofread your submission for spelling errors and correct track numbers.
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NetCD & AppleScript AppleScript allows users to automate their computer by writing simple instructions,
called scripts , which can control programs automatically. NetCD provides two levels of
AppleScript functionality: scriptability  and attachability .

Scriptable applications can be controlled through the use of AppleScript. By using simple
commands, you can instruct NetCD to perform actions or getting information. Scripts
can be written using a program like Script Editor from Apple Computer, Inc.

To view the commands available for controlling or getting information from NetCD,
choose “Open Dictionary” from the File menu of the Script Editor application and select
the NetCD application.

Attachable applications allow you to “attach” compiled scripts to the application for use
within the application. When you place compiled scripts in the Scripts folder (which
must be in the same folder as the NetCD application), these scripts appear in the Scripts
menu of NetCD. You can select a script from this menu to execute that script.

Scripts can be run automatically by NetCD when certain events occur. To specify a script
as being one that executes automatically, name the script one of the following names:

Mount —A script with this name will be executed automatically when an audio
CD is inserted.
Eject — A script with this name will be executed automatically when the CD is
ejected from the drive.
Play — A script with this name will be executed automatically when the user
presses the play button (or selects Play from the Disc menu).
Stop — A script with this name will be executed automatically when the user
presses the stop button (or selects Stop from the Disc menu).
Download — A script with this name will be executed automatically when
information is successfully downloaded from the CDDB internet database.
Unfound — A script with this name will be executed automatically when
NetCD has checked the CDDB but no information for the current CD was
found.

Jacket Notes I am indebted to all the individuals who made this program possible, most especially
Andrew Barry, Bob Blank, Scott Bush, Guillaume Grenier , Ti Kan, Jason Parsley, Geoff
Perlman, Steven Riggins and Steve Scherf. 

NetCD is freeware and may be distributed freely as long as all documentation is included.
NetCD may not be sold for profit under any circumstances. Toby W. Rush assumes no
responsibility for any damage or loss of data incurred by this program or its use.
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